Xperia XZ3でWiFi不具合、通信速度が異常に遅いとの報告、原因はAndroid 9.0の新機能か

ソニーモバイルの最新フラグシップモデル、Xperia XZ3。
国内ではドコモからSO-01L、auからSOV39、ソフトバンクから801SOとして先週発売。

価格.comの人気ランキングを見ている限り、前モデルのXZ2シリーズと比べてかなり好調な売れ行きのようですが、ユーザー数が増えるにつれ、ちょくちょくと不具合報告が出てきているのも事実です。

なかでもちょっと目立ってきているのがWiFi周りのトラブル報告で、具体的にはWiFi接続時の通信速度が異常に遅い、というもの。

Xperiaシリーズでは過去機種でもWi-Fi接続が途切れる、再接続しないといったトラブル報告は結構見かけますが、今回のものは接続はしているものの通信速度が異常に遅いというもので、今までの症状とはちょっと種類が違う模様。

ただ、ちょと調べたところ、類似の報告がAndroid 9.0アップデート直後のPixelなど、他機種でも挙がっていることが判明し、Xperia公式フォラム上でもAndroid 9へアップデート済みのXperia XZ2でも同様の報告あり。

よって、Xperia XZ3特有の不具合というよりAndroid 9.0、つまりOS起因の問題である可能性もたk層。

一方、海外フォラムや一部サイトなどではこの問題はAndroid 9.0でデフォルト搭載された新機能、「Wi-Fiを自動的にONにする」が原因との報告もあります。

この「Wi-Fiを自動的にONにする」はWi-FIを手動でオフにした場合でも、その後端末が再び保存済みのWiFi圏内に入ると自動的にWiFi接続を行う、という機能で9.0アップデート後のAndroid機種ではデフォルトでオンになる機能です。

この機能自体に何らかのバグが有るのかは不明ですが、どうやらこれをオンにしていると電波状況の悪いアクセスポイントでも自動的に接続されてしまい、電波の良いアクセスポイントへの接続が阻害される、というケースがある模様。

よって、一つの改善方法としては:

「設定」→「Wi-Fi」→「Wi-Fi設定」→「Wi-Fiを自動的にONにする」のトグルをオフ

という方法が紹介されています。

ちなみにXperia XZ3ユーザーから「WiFiをオフにしても勝手にオンになる」といった報告が散見されますが、これ自体は不具合ではなく、この「Wi-Fiを自動的にONにする」が原因。これをオフにすれば問題解決します。

一方、WiFi周りの不具合はルーター側の問題も含めて考えられる原因が多岐にわたります。
よって、上記の方法で全てのWiFi不具合が改善するとは限りません。

ただ、トグルをオフにするだけの簡単な対処法なので、とりあえず該当症状が出ている場合は試してみることをおすすめします。

コメント

  1. クロスケ より:

    「Wi-Fiを自動的にONにする」をoffにしてても、地下鉄とか移動中に勝手にwi-fiに繋ごうとするんだけど‥。
    保存済みネットワークの自動接続も家と職場以外は全部offにしたけどダメ。なので外出時はwi-fi自体をoffにしている。家に帰ってwi-fi入れ忘れたりすることもあり、とても不便。

  2. 中川 浩美 より:

    Xperia XZ3 SOV39を買いましたが、Wifiが自宅で繋がりません。Auショップに行ってWifi接続をすると問題なく繋がります。自宅では、家族は問題なくWifiが使えています。パソコンも全く問題がありません。Auショップの店員も冷たいし。どうしたらよいか分かりません。解決方法を教えてください。

  3. 通りすがり より:

    この問題、Xperia XZやZ3 TabletCompactでも発生していた、5GHz帯のAC規格で接続した場合だけ不安定になる「低速病」とは別物なんだろうか。いまだに治ってないんだよね。

  4. harap より:

    ウチのG8188でも昨日Android 9が落ちてきたのでupdateしたらWiFi周りでやはりトラブルが。
    2.4GHz/5GHz併用しているのだが、5GHzに切り替えてもすぐに2.4GHzにスイッチされたり、またしばらくすると勝手に5GHzに切り替わったりを繰り返しているもよう。しかも「Wi-Fiを自動的にONにする」をoffにしたら、一覧に表示されなくなったり(接続はしているもよう)と、なんだかなぁ。
    海外のサイトでは、DHCP→固定IPにして、DNSを安定した外部DNS(Googleとか)にしたら直ったって報告があったり、9.0.3?で直っていると報告があったりとやはり混乱状態。
    少なくとも2.4GHz「しかない」環境では2.4GHzの特定SSIDに固定されて切れることもないので、なんだ? 5GHzでおかしいのか?
    うむむ。

  5. Hoge より:

    ルータのMTU設定と端末の相性?が悪い疑惑。
    設定できる一番高い値にしたら、調子が良くなった。